ASUS Prime Z390-A Build

Get your PC tech problems solved here. Quick response time.

Moderator: The Mod Squad

Post Reply
Posts: 2
Joined: Wed Apr 07, 2021 3:05 pm

ASUS Prime Z390-A Build

Post by Impresario3585 »

CPU = Intel Core i7-9700K
RAM = 64GB AEGIS 2666
HEATSINK = Deep Cool
OS = Win 10 (never got there)
POWER SUPPLY = Corsair 1000W
CASE = Antec

When I power up the system I get stuck on a DRAM error LED light on the mobo. I took out all memory except one stick (16GB) and tried different sticks with the same problem.

I called ASUS who after a couple of questions, suggested it was a defective mobo and offered an RMA. Before going through all of that, does anyone have any thoughts on what I might have done wrong?

Thank you
User avatar
Mobo-fu Master
Mobo-fu Master
Posts: 37629
Joined: Sun May 06, 2001 12:01 am
Location: Netherlands

Re: ASUS Prime Z390-A Build

Post by evasive »

If you used the proper (listed compatible) memory, a proper (listed compatible) CPU, made sure you connected everything according to the manual, made sure there were no short circuits anywhere (mounting the board on standoffs helps preventing that):
From time to time a board will pass QA and turns out to be defective when actually put into a machine.

I'd be okay with an RMA then.
We hate rut, but we fear change.
System error, strike any user to continue...
Post Reply