The Mother Board
Incorrect Work Units..

 
Post new topic   Reply to topic    The Mother Board Forum Index -> Motherboards.org Folding Team
View previous topic :: View next topic  
Author Message
Karlsweldt
Mobo-fu Master
Mobo-fu Master


Joined: 12 Nov 2003
Posts: 19019
Location: 07438

PostPosted: Mon Sep 12, 2011 6:33 am    Post subject: Incorrect Work Units.. Reply with quote

Have been getting work units that are not intended for my system on several past instances.. possibly intended for GPU folding. The error message reads " The procedure entry point GetAdapterAddress could not be located in the dynamicl link library IPHLPAPI.DLL".
After perhaps six attempts at a new WU, then a unit is given that conforms to my system.
Yes, I am not "up to speed" with PCI-E video and possible GPU folding. But hey.. maybe the Stanford techs could flag a contributor as to what type of units to be sent? Don't want to give up a worthy cause, but if default units are not gotten, I may have to exit the F@H process.
_________________
F@H.. to solve mankind's maladies.. in our lifetimes!
Back to top
View user's profile Send private message
evasive
Mobo-fu Master
Mobo-fu Master


Joined: 06 May 2001
Posts: 36700
Location: Netherlands, Breda

PostPosted: Mon Sep 12, 2011 9:16 am    Post subject: Reply with quote

nothing to do with the unit but with your networking peer-to-peer setup. apparently some program is using that dll and it being the NT/2000 flavour, not all functions are implemented compared to the winXP variant. I'll check if I can find a more recent one for you.
_________________
We hate rut, but we fear change.



System error, strike any user to continue...
Back to top
View user's profile Send private message Send e-mail Visit poster's website Yahoo Messenger MSN Messenger
evasive
Mobo-fu Master
Mobo-fu Master


Joined: 06 May 2001
Posts: 36700
Location: Netherlands, Breda

PostPosted: Mon Sep 12, 2011 9:28 am    Post subject: Reply with quote

http://msdn.microsoft.com/en-us/library/aa365917%28v=vs.85%29.aspx

enlightening. My guess is the developer is checking for XP with windows being version 5, not 5.1. You should file a bug report for this one. What version client are you running?
_________________
We hate rut, but we fear change.



System error, strike any user to continue...
Back to top
View user's profile Send private message Send e-mail Visit poster's website Yahoo Messenger MSN Messenger
Karlsweldt
Mobo-fu Master
Mobo-fu Master


Joined: 12 Nov 2003
Posts: 19019
Location: 07438

PostPosted: Tue Sep 13, 2011 4:43 am    Post subject: Reply with quote

Yes, still using Windows 2000 Pro as the OS.. with an AGP video card, on the primary system. In the process of setting up a system with Win XP Home, but progress is slow.
I do have three files with that IPHLPAPI.DLL name.. and all dated 05/2006.
And no, I do not have 'broadband'.. only DSL. Could not find a newer version of that *.dll file, suitable for W2K. Did have a dial-up modem, but that feature and drivers have been removed.. in 2006, after going to DSL.
The F@H Console version is 5.04. Running as manual-start, not service-start.

System 1 basic specs:
Motherboard: ASRock Conroe 865PE Socket 775 [BIOS date 08/16/2006]
Windows 2000 Pro, SP4 plus all updates
AVG Internet Security Suite, licensed and auto-updated
Pentium 4 Prescott 2.80 Ghz 1 Mb L2, 800 FSB w/HT (520J)
2 x 1 Gb DDR 400 Corsair CMX1024-3200C2 @ 200 MHz [3.0-3-3-8]
nVidia GeF 7600GS AGP 8x 512 Mb
Seagate Barracuda 7200 RPM 80 Gb SATA II
550 watt Coolermaster Extreme PSU in ATX full tower

The 'newer' system is using my old Chaintech 848P mobo, similar setup.. but with Win XP Home as the OS.
If the budget had any leeway, I would have gone with a newer, PCI-E video system.
_________________
F@H.. to solve mankind's maladies.. in our lifetimes!
Back to top
View user's profile Send private message
evasive
Mobo-fu Master
Mobo-fu Master


Joined: 06 May 2001
Posts: 36700
Location: Netherlands, Breda

PostPosted: Tue Sep 13, 2011 8:50 am    Post subject: Reply with quote

I checked and 5.0.4 is windows 2000 compatible so it should not bother with iphlpapi not being the XP version. I think some other network-related program or service is complaining, it not being 2000-compatible anymore.
_________________
We hate rut, but we fear change.



System error, strike any user to continue...
Back to top
View user's profile Send private message Send e-mail Visit poster's website Yahoo Messenger MSN Messenger
Karlsweldt
Mobo-fu Master
Mobo-fu Master


Joined: 12 Nov 2003
Posts: 19019
Location: 07438

PostPosted: Thu Sep 15, 2011 6:53 am    Post subject: Reply with quote

Compared all three IPHLPAPI.DLL files.. identical. One is 'abandoned' in the old Win 98 install.. the other two are in the WINNT/System32 folder. In reading the error messages of the file, I have no associated broadband devices, no Wi-Fi devices, no dial-up modem. And no networked references. For 95% of operating time, only this #1 system is active.. the other stand-by computers are "off". And in checking for installed programming or devices, nothing abnormal. And no conflicts with any device assignments. Just odd that the F@H Console is looking for an adapter address.
Surely the techs at Stanford will note from the F@H log with each returned WU that there was a problem with unit association and my setup.
(excerpt:)
[Sept. 11, 2011]
+ Processing work unit
Core required: FahCore_a4.exe
Core found.
Working on Unit 02
+ Working ...
CoreStatus = 80 (128)
Client-core communications error: ERROR 0x80
- Attempting to download new core...
+ Downloading new core: FahCore_a4.exe
- Presenting message box asking to network.
-----------
Verifying core Core_a4.fah...
Signature is VALID
Trying to unzip core FahCore_a4.exe
Decompressed FahCore_a4.exe (10057216 bytes) successfully
+ Core successfully engaged

Deleting current work unit & continuing...
+ Attempting to get work packet
- Connecting to assignment server
- Successful: assigned to (xxx.xxx.xxx).
+ News From Folding@Home: Welcome to Folding@Home
Loaded queue successfully.
+ Connections closed: You may now disconnect
+ Processing work unit
Core required: FahCore_78.exe
Core found.
+ Working ...
_________________
F@H.. to solve mankind's maladies.. in our lifetimes!
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    The Mother Board Forum Index -> Motherboards.org Folding Team All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2002 phpBB Group