Problem with computer PSU

All hardware or software issues that do not have a specific forum go here.

Moderator: The Mod Squad

Problem with computer PSU

Postby rascard2007 » Wed Dec 03, 2014 7:28 am

I´m trying to repair an ATX/2 PC SMPS that has a funny behaviour.

switched to 115 V conected to 115 V = NO POWER UP
switched to 230 V conected to 230 V = NO POWER UP
switched to 230 V conected to 115 V = POWER UP, but output voltages are are almost the half as U can expect conecting in a lower input voltage

¿any clue on what is happening?
"I have only come here seeking knowledge,
Things they would not teach me of in college"
-Wrapped Around Your Fingers-
-The Police-
rascard2007
Black Belt
Black Belt
 
Posts: 720
Joined: Tue Jun 12, 2007 10:47 am
Location: Havana, Cuba

Re: Problem with computer PSU

Postby Karlsweldt » Wed Dec 03, 2014 11:58 am

If an ATX PSU, there is a 'standby' +5 volts present at all times when mains power feeds the PSU, and its power switch (if present) is "on". That is a violet wire at the back of the main ATX plug.
There is a fuse inside the PSU case, for protection. But hazardous voltages are present inside, so give extreme caution on not touching any exposed components inside! Easy to test the fuse with a neon socket tester or volt meter to case ground. If blown, it is for a reason. They only blow as a last resort. May be time for a new PSU.
Switching a PSU to 115 volt input if on 230 volt would definitely pop a fuse.. or fry the main control transistor that creates the chopped DC for the core transformer! If on a 115 volt feed and switch is set to 230 volts, insufficient circuit voltage to become active.
One other main reason for 'no-start' conditions is the BIOS battery being weak. It is a redundant backup for when there is no PSU +5 volt 'standby' feed when shut down. The BIOS battery keeps the real time clock proper, as well as retaining memory settings in the CMOS feature. If the real time clock is not functioning, bus and other clock circuits may not be active. Have seen that scenario too many times.
Any type of switching PSU needs a minimal load on the +3.3 or +5 volts, and the +12 volts to become operational. A dual-filament headlight bulb would be a safe load of about 3 amps each. Normally a 3 ohm 20 watt resistor is used for the +3.3 or +5 volt loading, and a 6 ohm 20 watt resistor for the +12 volt loading. But they get very hot very quickly!!

There is one critical tiny component on the PSU board. About 1/4" square with 4 leads. That is a photo-isolator diode, which interacts between the output and input control circuits. If bad, no activity.
F@H.. to solve mankind's maladies.. in our lifetimes!
Karlsweldt
Mobo-fu Master
Mobo-fu Master
 
Posts: 20690
Joined: Wed Nov 12, 2003 11:57 am
Location: 07438

Re: Problem with computer PSU

Postby rascard2007 » Wed Dec 03, 2014 1:43 pm

Many thanks, Karl

digging into the PSU I noticed some silicon glue crystalized around the main filter caps, I removed all and for now the PSU is working normally I have it in test in my workbench, conected to an spare mobo and a couple of old HDDs to provide enough load in all of the voltages.

for now, it seems to be solved, once i finish testing will comment about to you,

thanks again
"I have only come here seeking knowledge,
Things they would not teach me of in college"
-Wrapped Around Your Fingers-
-The Police-
rascard2007
Black Belt
Black Belt
 
Posts: 720
Joined: Tue Jun 12, 2007 10:47 am
Location: Havana, Cuba

Re: Problem with computer PSU

Postby Karlsweldt » Wed Dec 03, 2014 5:32 pm

That "glue" likely is either silicone or a polymer 'hot glue' type, meant to reinforce the large capacitors, to keep them in place. It should be inert, non-conductive.
Possibly there was a cold-soldered connection somewhere, and removal of that "glue" reestablished the connection.
Might be worth taking the PC board out of the PSU, and touching up any solder joints that look dull. Be cautious and quick with small components and transistors! Most PC boards for a PSU are wave-soldered, and pristine cleanliness is paramount with solder connection points.
F@H.. to solve mankind's maladies.. in our lifetimes!
Karlsweldt
Mobo-fu Master
Mobo-fu Master
 
Posts: 20690
Joined: Wed Nov 12, 2003 11:57 am
Location: 07438

Re: Problem with computer PSU

Postby evasive » Thu Dec 04, 2014 1:31 pm

What colour is that "glue"?
We hate rut, but we fear change.
********************************
System error, strike any user to continue...
evasive
Mobo-fu Master
Mobo-fu Master
 
Posts: 37389
Joined: Sun May 06, 2001 12:01 am
Location: Netherlands

Re: Problem with computer PSU

Postby rascard2007 » Wed Dec 10, 2014 2:08 pm

white and looks like a ceramic compound when u touch it
"I have only come here seeking knowledge,
Things they would not teach me of in college"
-Wrapped Around Your Fingers-
-The Police-
rascard2007
Black Belt
Black Belt
 
Posts: 720
Joined: Tue Jun 12, 2007 10:47 am
Location: Havana, Cuba

Re: Problem with computer PSU

Postby evasive » Wed Dec 10, 2014 11:28 pm

Some glue found in the really cheap made in china cr*p powersupplies is known to go off and then starting to conduct electricity. I expect the elctrolytic capacitors in this thing to bulge and then blow up pretty soon.

See http://www.badcaps.net for details on that. If your capacitors are one of the known bad brands it is not a matter if they will fail but only WHEN.
We hate rut, but we fear change.
********************************
System error, strike any user to continue...
evasive
Mobo-fu Master
Mobo-fu Master
 
Posts: 37389
Joined: Sun May 06, 2001 12:01 am
Location: Netherlands

Re: Problem with computer PSU

Postby rascard2007 » Fri Dec 12, 2014 5:48 am

The two main filter caps are Fujyyu 480 mF 200 V

the smaller ones in the secondary side are Canicor

I made some elementary tests on them and seems to be OK

is there any trouble in changing the main filters for a couple of 620 mf 200 V ones, the brand is Jay´Long
"I have only come here seeking knowledge,
Things they would not teach me of in college"
-Wrapped Around Your Fingers-
-The Police-
rascard2007
Black Belt
Black Belt
 
Posts: 720
Joined: Tue Jun 12, 2007 10:47 am
Location: Havana, Cuba

Re: Problem with computer PSU

Postby Karlsweldt » Fri Dec 12, 2014 11:54 am

The main capacitors are easy to change. But stay with the original value of capacitance and voltage! A higher voltage is acceptable, but never lower. The capacitance value is set by professional designers. For primary power capacitors, you could use a bit higher capacitance value. The temperature rating may be 85°C, should be 105°C even if in a PSU! But of greatest priority, use only known-good brands. The circuit board should have print on it, denoting the positive and negative terminals.. or a small circle that is half-shaded. The shaded side is negative.
Use only rosin-core solder, never acid-core for electronics work.
F@H.. to solve mankind's maladies.. in our lifetimes!
Karlsweldt
Mobo-fu Master
Mobo-fu Master
 
Posts: 20690
Joined: Wed Nov 12, 2003 11:57 am
Location: 07438

Re: Problem with computer PSU

Postby evasive » Sat Dec 13, 2014 10:01 am

In this case I disagree Karl. The main filter caps in that power supply are just enough for providing enough ripple reduction to chop into something decent on the outside so a bit bigger is better in this case.

Good brands:
http://www.badcaps.net/forum/showthread.php?t=2280

Now you can get away with using O(S)T or Taepo in the primary side because that is low-frequency stuff but on the secondary, don't go away from what is mentioned in the post.
however, I am really wondering if we should even try recapping this.

http://www.badcaps.net/forum/showthread.php?t=388
Fujyyu :-& Fuhjyyu
Canicor [-( Canicon

Both are real trash. The Jay' Long capacitors are of the same low quality so not a good idea. Seeing these bottom-of-the-line brands being used, I also fear for the design of the rest of the power supply. Sounds like it will go up in flames if pushed to more than 50% of its rated wattage. Seriously.
We hate rut, but we fear change.
********************************
System error, strike any user to continue...
evasive
Mobo-fu Master
Mobo-fu Master
 
Posts: 37389
Joined: Sun May 06, 2001 12:01 am
Location: Netherlands

Next

Return to General

Who is online

Users browsing this forum: No registered users and 1 guest