Marvell 614x RAID tech support and lack thereof for WinXP

A place where the most common PC questions are already answered for you.

Moderator: The Mod Squad

Marvell 614x RAID tech support and lack thereof for WinXP

Postby Amby19 » Sun May 03, 2009 6:10 pm

This OP describes three main problems with my getting RAID 0 to work on the Marvell 614x RAID chipset on my Asus P5WDG2 WS Pro mobo running XP Pro SP3, but quite a few other motherboards use the Marvell 614x RAID chipset, so I hope there are many here who are familiar with it.

My three issues are (in summary):

(I): I need to find more documentation in order to learn more about the Marvell 614x (fuller name: Marvell 88SE6145 RAID controller), and also to understand some specifics regarding creating RAID arrays: for example, for the "Init mode" parameter in the Marvell BIOS console, what do the values 'No' or 'Quick' mean and what is the difference between them? I cannot find this info either from Marvell's site, Asus' site, or Google searches.

(II): I need to find working versions of all the necessary Marvell support software, including the Marvell RAID Utility (MRU) for the Marvell 614x under Windows XP Pro SP3. I'm pretty sure I've found the correct driver on Asus' download page for the P5WDG2 WS Pro, but I cannot find everything I need either from Marvell's site, Asus' site, or Google. For example, I cannot find a working version of the Marvell RAID Utility (MRU): The version that came with the latest driver downloaded from the Asus download page is a disaster.

(III): I need technical assistance getting the RAID 0 array I've created using the Marvell 614x to boot XP. I used the exact same techniques with my P5WDG2 WS Pro as when I had perfect first-time success on my other XP Pro SP3 system (an Intel DQ35MP mobo with an ICH9R RAID controller), but while it worked perfectly on the Intel mobo, it doesn't work on the Asus mobo, probably because of issues (I) and (II) above.


Here's the procedure I followed so successfully with the Intel mobo:

(a): I began with a fully working XP Pro SP3 system on that machine, running from a normal, non-RAID, SATA disk.

(b): I physically installed two SATA 500 GB disks and connected them to the ICH9R ports (necessary before the BIOS will let you enable the RAID BIOS).

(c): I enabled the ICH9R RAID controller and BIOS in the system BIOS.

(d): I used the now-available ICH9R RAID controller's BIOS console to create some RAID 0 arrays. Then I rebooted up into Windows again from the normal, non-RAID, SATA disk.

(e): I visited the Intel web page for my DQ35MP mobo, and downloaded all the ICH9R drivers and support software and installed them all, then rebooted.

(f): Now that those previous steps had been accomplished, which made Windows aware that I now had a new hardware configuration, I visited the Windows Update site and performed a custom search for all updates of any kind. It found some updates relevant to the hardware configuration changes, so I downloaded them and installed them, then rebooted again.

(g): From within Windows (for greater speed than the standalone bootable CD permits), I launched Acronis Disk Director 10, which I used to copy the system partition (and others) from the standard SATA disk to the new RAID arrays.

(h): I then physically removed the SATA connectors from the mobo of all the non-RAID hard disks, leaving just the new RAID 0 arrays, the IDE DVD-ROM, and the floppy drive enabled.

(i): When I booted up Windows from the RAID array, everything worked perfectly! I haven't had a single problem since!


The nice thing about my approach is that it's the easiest possible approach: You don't have to worry about an F6 floppy and you don't have to worry about the whole "Found new hardware" drills, especially since "Found new hardware" too often doesn't even tell you what new hardware it found, so you can't tell what driver it wants. Trial and error and confusion is what you get when you take other approaches (according to all the complaints I've read from people trying to move their XP system to a RAID array).

---

SO: Naturally, I tried the exact same thing -- the same steps in the same order -- with my Asus P5WDG2 WS Pro and its Marvell 6145 RAID controller. With the proviso that Asus didn't provide everything I wanted (or thought I wanted) on their site, I followed every step exactly and every single one of them appeared to complete successfully. It was not until I got to step (i) and tried booting from the RAID array that it all fell apart. It would NOT boot from the RAID array no matter what I did.

Unfortunately, it would not even show a BSOD or crash or give some other error! If I'd had that, I might have had something to work from, or at least a more specific error for which I could ask for help. It just sat there, screen blank, all the typical lights and sounds in place, doing nothing.

Now, I read someone's comments somewhere that said that one should strongly prefer using the Intel ICH7R's RAID controller over the Marvell 614x RAID controller on the same (unspecified) motherboard. That person adamantly thought that a smart user would disable RAID mode on the Marvell 614x and connect one's SATA hard drives and SATA optical drives to the Marvell 614x connectors. He said that the Intel's RAID performance was far superior to the Marvell's.

Does anyone know if that's true? Can I get a second vote?

After reading that, I tried it, but the Marvell didn't seem to like being used in non-RAID mode. I saw a few odd behaviors that way, for example.

Even so, I'd try it again if I could be certain that the ICH7R's RAID mode would, in fact, provide considerably higher performance. What do you folks think?

(btw: I'm using an Antec Quattro 850 watt power supply in order to support the considerable power requirements of all those devices on my P5WDG2 WS Pro)


I sincerely thank everyone who read through all this verbiage, even if they can't offer a solution to my problem! I'm one of those who thinks that one's problem will much more likely be solved if one provides a lot of detail and a lot of context.

Thanks!
Amby19
Pilgrim
Pilgrim
 
Posts: 13
Joined: Mon Apr 14, 2008 7:26 pm
Location: Michigan

Postby evasive » Mon May 04, 2009 1:54 am

http://usa.asus.com/products.aspx?model ... 3=248&l4=0

Storage

Intel ICH7R controller supports:
- 4 x SATA 3.0Gb/s (RAID 0,1,10,5)
- 1 x UltraDMA 133/100
Marvell 88SE614x supports:
- 4 x SATA 3.0Gb/s


Nowhere any RAID option mentioned for the Marvell stuff, only for the Intel part, so a bit confused here.


http://en.wikipedia.org/wiki/List_of_Ma ... x_Chipsets
88SE6141 SATA II PCI-E controller Marvell 88SE6141 SATA/ATA controller :

1 xExternal SATA 3.0 Gbit/s - 3 xSATA 3.0 Gbit/s (RAID 0,1,10) - Thor 4S/1P
88SE6145 SATA II PCI-E controller Marvell 6145: 4 SATA2 300MB/s ports

Support software RAID 0, 1& 10 for Windows and Linux - Thor 4S/1P


Would mean you can make a raid set on it. But if it is the 88SE6145 the only way to do so is in software from within the OS which means in my book you can't boot from the thingy.

So far I have seen no performance issues with using Intel RAID controllers.
We hate rut, but we fear change.
********************************
System error, strike any user to continue...
evasive
Mobo-fu Master
Mobo-fu Master
 
Posts: 37389
Joined: Sun May 06, 2001 12:01 am
Location: Netherlands


Return to MBHW Q&A

Who is online

Users browsing this forum: No registered users and 1 guest