Acer IPIMB-AR Rev 1.02A

Get your PC tech problems solved here. Quick response time.

Moderator: The Mod Squad

Post Reply
Posts: 3
Joined: Wed Dec 30, 2020 4:40 pm

Acer IPIMB-AR Rev 1.02A

Post by Porch01 »

Hello all. I have a Gateway computer purchased in 2013. It is a DX4870-UB318. The motherboard is an Acer IPIMB-AR Rev 1.02A. It fails to boot to the bios. After turning it on, the fans startup and then it basically stops there. Nothing displayed on the screen. I have removed all connections to the motherboard. I have removed the battery for an hour. I have reset the CMOS. I have reseated the RAM sticks. I have tried only one stick of ram (two 4 GB sticks) at a time. I have tried a different power supply. Nothing seems to work. What other trouble shooting steps can I perform? Does someone have a copy of a bios that I can install directly to the mother board and what is the process to do this? Any help would be greatly appreciated. Thank you.
20201230_122230 test 2.jpg
User avatar
Mobo-fu Master
Mobo-fu Master
Posts: 37629
Joined: Sun May 06, 2001 12:01 am
Location: Netherlands

Re: Acer IPIMB-AR Rev 1.02A

Post by evasive »

replace the coin cell CR2032 with a fresh new one, pay attention to the sell-by date on the package as well.

Symptoms point at a flat CMOS battery.
We hate rut, but we fear change.
System error, strike any user to continue...
Post Reply