The Mother Board

Motherboards.org forums. Free tech support, motherboard ID, and more.
It is currently Thu Apr 02, 2020 7:14 pm




Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: Fri Mar 26, 2010 4:43 pm 
Offline
Pilgrim
Pilgrim

Joined: Sat Feb 11, 2006 4:32 pm
Posts: 14
Location: Adanac
Can WoL other computers on the network, but cannot get this Asus P5Q SE box to WoL. Hoping someone will be familiar enough with this mainboard to help out.

The board has built-in Gigabit Ethernet, which works fine (except for WoL). BIOS has no setting for WoL as far as I can tell.

BIOS has Wake on Keyboard enabled, and this works fine. Wake on Mouse, Wake on USB, etc are not enabled, as I don't use them.

BIOS also has settings for Wake on PCI and Wake on PCIe. I have tried with these settings both enabled and disabled, with results as described below.

In Windows XP Device Manager, properties for this device, Advanced tab, for the 'Wakeup Capabilities' setting I have tried both 'Magic Packet & PatternMatch' and 'All', which seems to make no difference.

On that same tab, for the 'Shutdown Wakeup' setting, I have tried both 'On' and 'Off', with results as described below.

On the 'Power Management' tab, the 'Allow this device to bring the computer out of standby' setting, I have tried both enabled and disabled, with results as described below.

Okay, so while keeping Windows WakeupCapabilites either MagicPacket&PatternMatch or All, then for the combination of BIOS WakePCI and WakePCIe, and Windows settings ShutdownWakeup and AllowDevice, I have tried the various combinations with only two different results:

1. Either the computer won't WoL and the Ethernet link (as reported by the router) is off when the computer is off (but the router shows the links for the other computers which do WoL as active when those computers are off), or

2. When the computer is turned off, the router shows the link as active, but in just a few moments the computer turns itself back on with no intervention! There is a note about this in the Windows PowerManagement tab of the device to the effect that allowing this device to bring the computer out of standby may cause the computer to periodically wake up to refresh its network status.

But the various combinations always yield one of the above two results, so if the link is active, the computer wakes itself up, and if the link is inactive, it can't be woken up!

Anyone any experience with this mainboard? Any other settings I should look into? Any other suggestions?

Help would be appreciated.


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Fri Mar 26, 2010 5:41 pm 
Offline
Mobo-fu Master
Mobo-fu Master
User avatar

Joined: Sun May 06, 2001 12:01 am
Posts: 37585
Location: Netherlands
Power -> APM -> Power On by PCI Devices = Enabled

Network Card properties, Advanced, Shutdown Wakeup (or something similar) = Enabled
WakeUp Capabilities = Magic Packet

that should work. You have got the latest bios and drivers for the network adapter? This kind of bug is usually solved in a later revision of the driver or the bios.

_________________
We hate rut, but we fear change.
********************************
System error, strike any user to continue...


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Fri Mar 26, 2010 6:19 pm 
Offline
Pilgrim
Pilgrim

Joined: Sat Feb 11, 2006 4:32 pm
Posts: 14
Location: Adanac
Thanks for the quick response, evasive. Though I'm sure I've tried those settings, I will try them again!

Does it matter whether PowerManagement->AllowDeviceOutOfStandby is enabled or disabled?

Also, the drivers were latest last time I checked, but will also check them again.


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Sat Mar 27, 2010 12:54 am 
Offline
Mobo-fu Master
Mobo-fu Master
User avatar

Joined: Sun May 06, 2001 12:01 am
Posts: 37585
Location: Netherlands
reset the driver to defaults, then set the two things I told you, at least that is what is working for someone else using a similar Asus board.

_________________
We hate rut, but we fear change.
********************************
System error, strike any user to continue...


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Sat Mar 27, 2010 2:52 pm 
Offline
Pilgrim
Pilgrim

Joined: Sat Feb 11, 2006 4:32 pm
Posts: 14
Location: Adanac
Thanks, evasive. Okay, I have made the settings as you describe, with PowerManagement -> AllowDeviceOutOfStandby disabled. The only thing different here from the combinations I previously tried, is 'MagicPacket' instead of either 'MagicPacket&PatternMatch' or 'All'.

The result is that now, when the computer is turned off, the router link LED remains lit and the computer does not automatically turn itself back on, BUT neither can I WoL the computer. I'm using the same protocol as does work to wake the other computers. I've tried two different softwares to send the magic packet. And yes, I've double-checked and triple-checked the MAC address.

What to try next?

EDIT: Don't know if this datum will make any difference but, with the computer turned off the router shows the 'Link/Traffic' LED on--this LED is on solid and flashes when there is traffic for this port. BUT, the same port's 'Speed' LED (on the router) is OFF--this LED is normally off for 10Mbps (or when no link), yellow for 100Mbps, and green for 1000Mbps, and it remains lit for the other computers when turned off; for this computer it is green when the computer is on.


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Sun Mar 28, 2010 4:56 am 
Offline
Mobo-fu Master
Mobo-fu Master
User avatar

Joined: Sun May 06, 2001 12:01 am
Posts: 37585
Location: Netherlands
Hmmm I have to brush off my networking knowledge, bit rusty. I recognize the problem, now what did we do to solve this... 3-4 years is a looong time...

_________________
We hate rut, but we fear change.
********************************
System error, strike any user to continue...


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Sun Mar 28, 2010 3:42 pm 
Offline
Pilgrim
Pilgrim

Joined: Sat Feb 11, 2006 4:32 pm
Posts: 14
Location: Adanac
Haha... don't know if the board (P5Q SE) is that old, or just the problem--I built this box about a year ago.

Could try with PowerManagement -> AllowDeviceOutOfStandby enabled, though I suspect that may be the setting that causes the computer to wake up on its own shortly after shutting down... or would that be caused by enable Wake on PCIe in BIOS?


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Tue Mar 30, 2010 1:18 pm 
Offline
Pilgrim
Pilgrim

Joined: Sat Feb 11, 2006 4:32 pm
Posts: 14
Location: Adanac
Okay, have tried with PowerManagement -> AllowDeviceOutOfStandby enabled. This setting seems to make no difference; with all other settings as reported above, whether AllowDeviceOutOfStandby is enabled or disabled, the computer does not wake itself up, but also will not WoL.

So, it seems that the computer waking itself up after shutdown must have been caused either by the BIOS Wake on PCIe enabled setting (why?), or by using MagicPacket&PatternMatch (or ALL) instead of just MagicPacket (again, why?).

Still no light on getting computer to WoL.

What should I try next?


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Wed Mar 31, 2010 5:40 am 
Offline
Mobo-fu Master
Mobo-fu Master
User avatar

Joined: Sun May 06, 2001 12:01 am
Posts: 37585
Location: Netherlands
on PCIe: it depends on where the LAN chip is interconnected, on the PCI bus or already on the PCIe bus.

Don't know what patternmatch is but I guess it's something to prevent other devices do WoL on your machine whereas the only true WoL server knows the secret code instead of all FF.

I have to check the driver properties of that onboard LAN thingy to see what would make sense here.

Other question, what networking stuff is in between (brand/model/age of the switches/routers whatever)?

What are you using for sending the WoL packet?

_________________
We hate rut, but we fear change.
********************************
System error, strike any user to continue...


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Wed Mar 31, 2010 1:56 pm 
Offline
Pilgrim
Pilgrim

Joined: Sat Feb 11, 2006 4:32 pm
Posts: 14
Location: Adanac
Okay, I enabled BIOS Wake on PCIe. This didn't change the router LEDs (Link LED on but Speed LED off, when computer off), and the computer didn't wake itself up. BUT, the computer now DOES WoL!

This is strange, since it was enabling BIOS Wake on PCI which caused Link LED to stay on--perhaps I could now disable that setting without detriment, but I haven't tried it.

So the working settings at this point are:
BIOS Wake on PCI = enabled
BIOS Wake on PCIe = enabled
Driver 'Shutdown Wakeup' = on
Driver 'WakeUp Capabilities' = 'Magic Packet'
Driver 'Allow this device to bring computer out of standby' = disabled.

Though it is now redundant, to answer your questions, all computers (and other gigabit devices, such as NAS) are connected via cat6 to an eight-port gigabit switch, which is connected to a gigabit router configured as DHCP server (so yes, the LEDs referred to above are actually on the switch rather than the router). The router also has some 10/100 devices attached (network printer, etc.). All devices are set to DHCP, and the router has a reservation for each device (based on MAC), so each device always obtains the same IP address.

Thanks so much for taking the time to help. Any comments on the reasons behind this are welcome. If you'd like me to try any other settings, let me know.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next


Who is online

Users browsing this forum: Majestic-12 [Bot] and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group