"stereo mix" under recording devices

Get your PC tech problems solved here. Quick response time.

Moderator: The Mod Squad

"stereo mix" under recording devices

Postby bdub » Fri Oct 14, 2016 8:07 am

win10 and the hp zbook 15 g3 laptops we sell do not provide a recording device "stereo mix". it was the same on win7, but there was a fix for it by editing some registry keys. this same fix doesn't work for win10, unfortunately. the audio chip is from Conexant. tried hacking chdrt.inf file in the hp driver package for audio too. no dice.
anybody out there find a way to enable stereo mix on Conexant chips in win10?

TIA.
my main rig...
asrock 970 extreme3
AMD FX-6300 Vishera CPU
zalman cpns5x performa hs/fan
crucial ballistix 2x4gb sport ddr3-1333
powercolor ax7750 1GBK3-H vga
antec neo he 650r
Samsung 840 EVo SSD 120 GB
toshiba 2TB HDD 64M cache sata3
seagate 1TB HDD 64M cache sata3
hitachi 2TB HDD 64M cache sata3
lg wh14ns40 bd burner
optiarc ad-7240s sata dvdrw (nec chipset)
bdub
Black Belt 3rd Degree
Black Belt 3rd Degree
 
Posts: 3668
Joined: Wed Feb 19, 2003 2:12 am
Location: Washington D.C.

Re: "stereo mix" under recording devices

Postby evasive » Sat Jan 28, 2017 3:02 pm

What is your registry hack for this? Maybe it needs a bit of massaging to fit into windows 10
We hate rut, but we fear change.
********************************
System error, strike any user to continue...
evasive
Mobo-fu Master
Mobo-fu Master
 
Posts: 37452
Joined: Sun May 06, 2001 12:01 am
Location: Netherlands

Re: "stereo mix" under recording devices

Postby bdub » Tue Feb 07, 2017 12:49 pm

thanks for replying...
so, you need a certain Conexant driver package from hp, uh, including or before sp75820. I can get the driver version number if you need, but let's just say this fix doesn't work on windows 7 after they released a newer version of the audio driver.

three regfiles...
ControlSet001.reg, which contains...
[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\EPattributes\EpSettings\StereoMixEnable]
"Enable"=hex:01
"MixAssocSeq"=hex:e0,e0
"MuteGainSettings"=hex:00,00

ControlSet002.reg, which contains...
[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\EPattributes\EpSettings\StereoMixEnable]
"Enable"=hex:01
"MixAssocSeq"=hex:e0,e0
"MuteGainSettings"=hex:00,00

Stereo Mix.reg, which contains...
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\EPattributes\EpSettings\StereoMixEnable]
"Enable"=hex:01
"MixAssocSeq"=hex:e0,e0
"MuteGainSettings"=hex:00,00

I had a better idea what all these did back when I posted this originally. I'm a little fuzzy now, except I know this fix, and others ive tried on multiple driver install versions have not worked on windows 10.

now, we also use windows 10 on a desktop platform that uses realtek audio chips, and we have yet to have this problem with those.
any questions, I'm happy to answer.
my main rig...
asrock 970 extreme3
AMD FX-6300 Vishera CPU
zalman cpns5x performa hs/fan
crucial ballistix 2x4gb sport ddr3-1333
powercolor ax7750 1GBK3-H vga
antec neo he 650r
Samsung 840 EVo SSD 120 GB
toshiba 2TB HDD 64M cache sata3
seagate 1TB HDD 64M cache sata3
hitachi 2TB HDD 64M cache sata3
lg wh14ns40 bd burner
optiarc ad-7240s sata dvdrw (nec chipset)
bdub
Black Belt 3rd Degree
Black Belt 3rd Degree
 
Posts: 3668
Joined: Wed Feb 19, 2003 2:12 am
Location: Washington D.C.

Re: "stereo mix" under recording devices

Postby evasive » Tue Feb 07, 2017 1:14 pm

It points at the MultiMedia Class for devices:
https://msdn.microsoft.com/en-us/librar ... 2147217396

It seems you don't need to mess in the registry this time:
https://answers.microsoft.com/en-us/win ... 23d84bc5bc

Provided you already removed the semicolons from the .inf file.
We hate rut, but we fear change.
********************************
System error, strike any user to continue...
evasive
Mobo-fu Master
Mobo-fu Master
 
Posts: 37452
Joined: Sun May 06, 2001 12:01 am
Location: Netherlands


Return to Tech Support

Who is online

Users browsing this forum: Bing [Bot] and 2 guests