The Mother Board

Buffalo DriveStation HD-LX3.0TU3 not recognised
Page 1 of 1

Author:  GaryG [ Mon Oct 03, 2016 11:05 am ]
Post subject:  Buffalo DriveStation HD-LX3.0TU3 not recognised

When I connect the USB, Windows tries to install the driver, but the unit is always listed in Devices/Printers as "Unspecified"

When I try Windows Devices Troubleshooting, Windows tries to reinstall the driver but always gives a failed result.

The light at the front of the unit is always red, whereas when it was working it was blue.

Although my main Operating-System is Windows 10 Professional 64-bit, I have also tried Windows 7 SP1 Professional 64-bit and Windows 7 SP1 Professional 32-bit, but all have the same problem.

If the unit cannot be fixed, is there anyway to recover the data?

Author:  Karlsweldt [ Mon Oct 03, 2016 3:46 pm ]
Post subject:  Re: Buffalo DriveStation HD-LX3.0TU3 not recognised

External USB 3.0 1 TB drive? Listen for a faint whir as it is powered up. If not, then try another USB port. If still no, then try on another system it was known to work on.
There was an old trick many years ago, with a hard drive that would not spin up. Give it a few quick twists along the axis of the platter, and give a try. But in those days, the platters were much larger and heavier than what is used today.

Author:  GaryG [ Tue Oct 04, 2016 9:23 am ]
Post subject:  Re: Buffalo DriveStation HD-LX3.0TU3 not recognised

Thanks Karl, yes it's a 3TB External USB drive: ... -velocity/

I don't know how these things work, so may be a stupid question, but, can I open the casing and be able to connect it using another IDE/SATA to USB adapter?

I contacted Buffalo and they offered me a replacement, if I send this one back, but this is not an option for me because the critical thing for me is the data on the broken unit, and if I send it back, I lose everything!

Author:  Karlsweldt [ Tue Oct 04, 2016 3:22 pm ]
Post subject:  Re: Buffalo DriveStation HD-LX3.0TU3 not recognised

Try another device on the USB port, to see if it is active.
The drive is listed as backward-compatible to USB 2.0 standards.
If you don't hear that faint whir as it is powered, then possibly the platter servo motor cannot spin the platters and do its warm-up exercise, and ID itself. Try another USB cable. Those thin ones don't take kindly to a lot of flexing.
Last option would be a line-powered USB hub which may provide more current.
Opening the case may void its warranty. If the small hard drive (notebook or laptop design) has an IDE or SATA connector, good chance it can be connected into the main drive system. There are adapters for the small (2.5") drive to standard PATA, as well as SATA.

Page 1 of 1 All times are UTC - 8 hours
Powered by phpBB® Forum Software © phpBB Group