Page 1 of 1

motherboard power error question

PostPosted: Thu Feb 04, 2016 7:23 pm
by Gixxxer
motherboard is evga z68 FTW. Power through the case switch is not working. power supply is good. there is a separate power switch on the mobo itself. Tried shorting the pins that the psw lead connects to for the switch, still no turn on. Assumption is that that area is bad..... correct? Just curious if anyone has experience in is this usually caused by a cap going bad or a cold solder joint at the pins or something? If so how hard is it to repair if possible. I have intermediate soldering skills. I have had this mobo for 4 years and no issues till now. Also just in case anyone was wondering I built this rig myself, its not a production rig.

Any help by the community is appreciated.

Re: motherboard power error question

PostPosted: Fri Feb 05, 2016 9:30 am
by Karlsweldt
Check that the idle or stand-by voltages are present at the main ATX power socket.
One is a violet lead at back, opposite the latch. That is the +5 volt stand-by for USB and BIOS needs.
There is a green lead to the right of the latch, that is the PS_ON lead. Should be about +5 volts when the PSU is not active.
It is shunted to return (black) to enable the PSU. Use a digital meter to measure, so as not to load the circuit.
If the PSU becomes active yet no life from the motherboard, maybe the BIOS battery has died. Only as a backup for when no mains power gets into the PSU. If the real-time clock stops, could cause a no-start condition.
There is one other lead from the PSU, the PG or 'power good'. That is a gray wire opposite the latch. Should be very close to +5 volts on that when the PSU is active, to signal timers and bus clocks to action. If not very close to that +5 volt level, then no motherboard life signs.
In situations like this, a POST diagnostics card is a handy too. Displays each POST step, and if a set of characters hangs, that is a clue as to what the problem may be.

Re: motherboard power error question

PostPosted: Tue Feb 09, 2016 4:19 pm
by evasive
Gixxxer, are you trying to tell the other separate power button on the board actually works then?