USB's split causes disconnects on some devices

Get your PC tech problems solved here. Quick response time.

Moderator: The Mod Squad

USB's split causes disconnects on some devices

Postby Roach412 » Fri Jan 02, 2015 12:18 pm

i'm using a Sabrent 4-Port USB 2.0 32FT Active Extension Flexible Hub (CB-HUB4):
http://www.amazon.com/Sabrent-4-Port-Ex ... B00E4NI59C

this is connected to the rear of my case(Lian Li Lancool First Knight Series PC-K59W) to my mobo(EVGA X58 FTW3 132-GT-E768-TR) - routed to individual keystone jacks/wallplate on my wall.

issue i'm having is with my 3 devices currently plugged in:
mouse - logitech mx518
keyboard - saitek eclipse II
gamepad - generic brand, USB xbox360 clone for PC

when i plug in a 4th device - specficically my phone(LG G2) in order to charge it, it kicks off one of my other devices...normally my mouse. if i disconnect the mouse and reconnect it then the mouse, and everything else, work again. i know the USBs on this board aren't high-powered, but can't find their actual rated limits for draw...

i'm thinking of getting a separate PCI or PCIE to USB card which should provide ample power(if that is the problem). if that's the case, any recommendations? don't NEED 3.0, but if it's economical i'd do it since the board supports it easily enough.

-Roach
Lian Li Lancool First Knight Series PC-K59W
Intel Core i7-960 Bloomfield 3.2GHz
EVGA X58 FTW3 132-GT-E768-TR
EVGA GeForce GTX 1070 FTW GAMING ACX 3.0
G.SKILL Ripjaws Series 12GB (3 x 4GB)
Crucial M4 128gb SATAIII SSD x2
Crucial M4 256gb SATAIII SSD
OCZ Saber 1000 960GB Enterprise SSD
Corsair Professional Series HX850 PSU
Dell UltraSharp U2713HM 27" w/drop ceiling mount
Logitech G930 7.1 Headset
DBPOWER RGB LED Keyboard
Logitech G402 Hyperion Fury
Roach412
Black Belt 2nd Degree
Black Belt 2nd Degree
 
Posts: 2714
Joined: Mon Aug 09, 2004 7:33 pm
Location: Milwaukee - Wisconsin

Re: USB's split causes disconnects on some devices

Postby Mr T » Fri Jan 02, 2015 12:27 pm

Max draw on a single USB port is 500ma. If the cable is unpowered (passive) then you are pushing its limit by adding another device, so one will get kicked off. I would swap it for a mains powered hub. Alternatively if there is a spare PCI-e slot, get a USB 3 card and use the ports from that - USB 3 gives a greater current draw to give super speed USB. Its backward compatible with USB 2 and 1 so your stuff will work.
I have been programming on computers since the ZX81.
I am an apprentice trained Electronics Engineer with qualifications to back it up.
I have been repairing computers since 1996.
Yet to some people I still know nothing...
Mr T
Enlightened Master
Enlightened Master
 
Posts: 17087
Joined: Fri Jun 14, 2002 1:03 am
Location: England


Return to Tech Support

Who is online

Users browsing this forum: Exabot [Bot] and 2 guests