The Mother Board

Motherboards.org forums. Free tech support, motherboard ID, and more.
It is currently Fri Sep 21, 2018 7:42 pm

All times are UTC - 8 hours




Post new topic Reply to topic  [ 16 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: Sat Apr 02, 2005 5:41 pm 
Offline
Black Belt 1st Degree
Black Belt 1st Degree

Joined: Tue Jan 27, 2004 8:08 pm
Posts: 1248
Location: Venezuela
Hey, guys. I just recently got myself some hosting and a domain. I'm currently working on the site but I just checked the site on IE instead of firefox and what do you know, its all broken.

http://www.spiralcorp.org/index2.htm


Heres the code
Code:
<html>
<head>
<title>Spiral Corp</title>
</head>

<body bgcolor="#424542" > <font face="Arial, Helvetica, sans-serif">
<table width="800" height="580" border="0" align="center" cellpadding="0" cellspacing="0">
<!-- Banner -->
      <tr>
      <td height="20%">blah
      </td>
      </tr>

<!-- /Banner -->
<!-- Body -->
      <tr>
      <td height="75%">
      
         <table border="1" rules="none" bordercolor="#636563" height="100%" width="100%"
               cellpadding="0" cellspacing="0">

            <tr>
<!--Images-->
               <td width="55%" valign="middle" align="left">
                  <table height="80%" width="100%" bordercolor="#636563" border="1" rules="none">
                     <tr>
                        <td>&nbsp;
                        </td>
                     </tr>
                  </table>
               
               </td>
<!--/Images-->         

<!-- Text content -->               
               <td width="40%" align="right" >

                  <table  border="0" cellpadding="3" cellspacing="0" width="90%"
                        rules="none" height="70%">
                     
                     <tr>
                        <td align="center" height="5" bgcolor="#525552">
                        <font face="Verdana, Arial, Helvetica, sans-serif" color="FFFFFF" size="-1">
                        <b>Title</b>
                        </font>
                        
                        </td>

                     </tr>
                     <tr valign="top" bgcolor="3D3D3D">
                        <td>
                        <font face="Verdana, Arial, Helvetica, sans-serif" color="CECFCE" size="-1">
                        <br>
                        &nbsp;Text from the texas tex text text textor textiness texter
                        </font>
                        </td>
                     </tr>
                     <tr align="right" valign="top" bgcolor="3D3D3D">
                        <td height="10%">
                        <font face="Verdana, Arial, Helvetica, sans-serif" color="CECFCE" size="-1">
                        <hr color="CEFF63" width="80%">
                        
                        Contact
                        </font>
                        </td>
                     
                     </tr>
                  </table>

               </td>
<!-- /Text content -->               
         
<!-- Navigation -->
               <td width="10%" valign="middle" align="right"><img src="nav.png">
               </td>
               <td width="10%" valign="middle" align="right"><img src="navt.png">
                  <table bgcolor="#636563" border="0" bordercolor="#636563" rules="none"
                        height="60%" width="100%" align="right" valign="top">

                     <tr>

                        <td  valign="top" align="right" height="10%">
                        <font size="-1" color="#FFFFFF"
                            face="Verdana, Arial, Helvetica, sans-serif" >

                            <b> Navigation</b> <br>
                            <hr color="CEFF63" width="65">
                            </font>
                        </td>

                     </tr>
                     <tr>
                        <td valign="top" height="10%"><font color="CECFCE"
                           face="Verdana, Arial, Helvetica, sans-serif" size="-1">
                           <li>Home</li>

                           
                           </font>
                           
                        </td>
                     </tr>
                     <tr>
                        <td valign="top" height="10%"><font color="CECFCE"
                           face="Verdana, Arial, Helvetica, sans-serif" size="-1">
                           <li>Pencils</li>

                           </font>
                        </td>
                     </tr>
                     <tr>
                        <td valign="top" height="10%"><font color="CECFCE"
                           face="Verdana, Arial, Helvetica, sans-serif" size="-1">
                           <li>Pencils</li>

                           </font>
                        </td>
                     </tr>
                     <tr>
                        <td valign="top" height="10%"><font color="CECFCE"
                           face="Verdana, Arial, Helvetica, sans-serif" size="-1">
                           <li>Colors</li>

                           </font>
                        </td>
                     </tr>
                     <tr>
                        <td valign="top" height="10%"><font color="CECFCE"
                           face="Verdana, Arial, Helvetica, sans-serif" size="-1">
                           <li>Photos</li>

                           </font>
                        </td>
                     </tr>

                     <tr>
                        <td valign="top" height="10%"><font color="CECFCE"
                           face="Verdana, Arial, Helvetica, sans-serif" size="-1">
                           <li>Contact</li>

                           </font>
                        </td>
                     </tr>
                     <tr>
                        <td valign="top" >
                        </td>
                     </tr>
                  </table>
                  <img src="navb.png">
               </td>

<!-- /Navigation -->            
            </tr>
         
         </table>
      
      </td>

      </tr>
<!-- /Body -->
<!-- Bottom -->
      <tr>
      <td height="5%">blah
      </td>

      </tr>
<!-- /Bottom -->

</table>
</font>
</body>

</html>


What am I doing wrong guys? (I know I'm probably not a very orthodox coder, but thats one of the perks of being self taught :roll: )

Thanks for the help :)

_________________
Image


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Sat Apr 02, 2005 8:05 pm 
Offline
Lead Mobo-fu Master
Lead Mobo-fu Master

Joined: Sun Dec 16, 2001 1:01 am
Posts: 14301
Location: Maine
I am working on a mockup page for you...Part of the problem that I saw was you images used around your nav bar are not sized have no size specs and/or are not size properly.... Hence why you are seeing a "broken look"

_________________
Compaq-Fu Master
Ctechinfo funding drive information


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Sat Apr 02, 2005 8:59 pm 
Offline
Black Belt 1st Degree
Black Belt 1st Degree

Joined: Tue Jan 27, 2004 8:08 pm
Posts: 1248
Location: Venezuela
Thanks man. Yknow, I sized the images to fit perfectly into the site. It worked with firefox and all. I have no idea why the bottom nav image (navb.png) shows up all the way up there on IE. What gives? I looked at the code and I dont see how to fix it.

I considered dumping the whole thing and starting from scratch with IE instead of firefox. But that would be running away from the problem. I want to know why IE is screwing it up. :?

_________________
Image


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Sat Apr 02, 2005 9:11 pm 
Offline
Lead Mobo-fu Master
Lead Mobo-fu Master

Joined: Sun Dec 16, 2001 1:01 am
Posts: 14301
Location: Maine
Quote:
It worked with firefox and all
I dont use alternate browsers. I only use IE and thats what I code for is for use with IE...

I am still working on the mockup (along with about 5 other projects). Should have it ready by morning.

_________________
Compaq-Fu Master
Ctechinfo funding drive information


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Sat Apr 02, 2005 10:42 pm 
Offline
Black Belt 1st Degree
Black Belt 1st Degree

Joined: Tue Jan 27, 2004 8:08 pm
Posts: 1248
Location: Venezuela
http://www.spiralcorp.org/index3.htm

Restarted the whole thing using IE to debug this time.

Still wont listen. To the right, the two top and bottom images. They wont connect to the other row, in firefox it looks like one big image but IE separates them. I know theres a way to fix this cause I've done it in the past but for the life of me I cant remember.

Any ideas?


Edit: Heres a simplified version with just the problem parts to make it easier on anyone trying to help. In IE you will see 3 greyish images. It should be one solid image (the top and bottom images should connect to the middle table)

http://www.spiralcorp.org/test.htm

_________________
Image


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Sun Apr 03, 2005 12:09 am 
Offline
Lead Mobo-fu Master
Lead Mobo-fu Master

Joined: Sun Dec 16, 2001 1:01 am
Posts: 14301
Location: Maine
Bah, I am having no luck with it. Unless I recode the whole navbar table... Besides I code for IE, so what looks ok on one browser will not always look good on another...

Have you looked into thead, tbody, and tfoot tags?

_________________
Compaq-Fu Master
Ctechinfo funding drive information


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Sun Apr 03, 2005 8:37 am 
Offline
Black Belt 1st Degree
Black Belt 1st Degree

Joined: Tue Jan 27, 2004 8:08 pm
Posts: 1248
Location: Venezuela
Wow, is connecting the two images so hard? Nevermind the original design. Just the ones in the test.htm page. If I do that I can probably recode the whole thing for IE. I just dont get why they wont connect, I mean, cellspacing and padding is 0. There should be no space between them damnit. :x

_________________
Image


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Sun Apr 03, 2005 1:00 pm 
Firefox(a simple browser) may just use one framebuffer per webpage, and gets everything on one page right.

IE6.0 uses banners or many frames? Even Yahoo could not handle the fonts(size designation), which over run the space allowed on IE6.0 webpage. I have found that each frame has to have a font size limitation set, based on linotype font sizes(so many per linear inch). So, the number of characters in a frame limits the font size, etc.

Html is not good to divide a webpage into many frames. To use html properly in IE6.0; each frame(ansi graphics sized dialog box) has to have a different set of html codes inside the ansi real estate. You have to print an array(string) of html codes in each allocated space defined by ansi dialog box.


Top
  
Reply with quote  
 Post subject:
PostPosted: Sun Apr 03, 2005 4:47 pm 
Offline
Black Belt 1st Degree
Black Belt 1st Degree

Joined: Tue Jan 27, 2004 8:08 pm
Posts: 1248
Location: Venezuela
Thanks for the technical insight atang, we can always count on you for that. But that doesnt really help me at the moment.

I need to find a way to get those images and tables together so they can share fluids and make one happy newborn site. :wink:

Come on, it cant be impossible, can it? You guys know way more than I, give the test.htm page a look, maybe you can find out what I'm doing wrong?

_________________
Image


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Sun Apr 03, 2005 6:08 pm 
Offline
Black Belt 1st Degree
Black Belt 1st Degree

Joined: Tue Jan 27, 2004 8:08 pm
Posts: 1248
Location: Venezuela
Hey guys, I fixed it. Added some align code to the images. "align="absbottom"" to the top one and "align=texttop"" to the bottom one.

Thanks for the help. 8)

_________________
Image


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 16 posts ]  Go to page 1, 2  Next

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group