Total Newbie - Setting up pc to pc network with xover cable

Moderator: The Mod Squad

Total Newbie - Setting up pc to pc network with xover cable

Postby jimmylad007 » Sat Sep 04, 2004 2:52 am

Hi. I am a total newbie at networking, this is my first attempt. I need to link a deskop to a laptop. I have a crossover cable. I can get as far as it saying local area connection connected etc, and from the laptop I can see both PCs. (Though I cannot access the other PC's files). From the other pc, I cannot see the other computer. I need to know how to set it up to share files only. All I need it for is file transfers. Thanks.
jimmylad007
Green Belt
Green Belt
 
Posts: 171
Joined: Fri Jun 11, 2004 6:16 am

Postby dr_st » Sat Sep 04, 2004 3:29 am

I'm gonna try to explain it from the beginning, so you may find that you have already taken some of these steps.

First of all, which operating system is on both machines?

If both runs Windows XP, you should simply run the network setup wizard on both machines, answer the wizard's question according to your network, and it should work (sometimes you may need to reboot both machines to have the network settings take effect).

If only one of the machines runs Windows XP and the other runs Win9x, you run the network setup wizard on that machine. In the end it will suggest you to create a network setup floppy to run the wizard on the machine that runs Win9x. You take that floppy and run the wizard (Netsetup.exe) on the other PC.

I must admit that I am not sure whether Win2K needs the floppy to run the wizard or not.

Setting up global file sharing is not difficult either. From the PC whose files you want to share, go to "My Computer". Select the hard disk, go to "Properties", then "Sharing". There you should find all the options you need to share the entire hard disk and also to allow the other PC to modify your files.

This should get you started, if something is not clear enough, feel free to ask.
dr_st
Black Belt 2nd Degree
Black Belt 2nd Degree
 
Posts: 2191
Joined: Tue May 11, 2004 11:18 pm
Location: Outworld

Postby jimmylad007 » Sat Sep 04, 2004 6:37 am

It's Ok I've sorted it now anyway. I can't share internet connection though. Can you talk me through that? Both machines are on XP.
jimmylad007
Green Belt
Green Belt
 
Posts: 171
Joined: Fri Jun 11, 2004 6:16 am

Postby Hardware Junkie » Sat Sep 04, 2004 6:41 am

jimmylad007 wrote:It's Ok I've sorted it now anyway. I can't share internet connection though. Can you talk me through that? Both machines are on XP.


WHich machine has the internet connection? And I assume its using 2 NIC cards? Or is there a USB modem?
"Imagination is the only weapon in the war against reality." -Jules de Gautier

Image
Hardware Junkie
Mobo-fu Master
Mobo-fu Master
 
Posts: 19405
Joined: Thu Jan 25, 2001 1:01 am
Location: 00000h - 0000Fh

Postby jimmylad007 » Sun Sep 05, 2004 5:02 am

The desktop has the internet connection (yes it's a USB modem). They both have bog standard 10/100 LAN connections on board.

Also I can only access from one way. I can access the laptop's hard drive from the desktop, but when I try to access the desktop's hard drive from the laptop I can't. It does not show up on "my network places" on the laptop, and double clicking the desktop in "view workgroup computers" gives an access denied error.

I don't need it straight away, but it's just when my friend brings his laptop round so we can share files and internet connection then.
jimmylad007
Green Belt
Green Belt
 
Posts: 171
Joined: Fri Jun 11, 2004 6:16 am

Postby jimmylad007 » Sun Sep 05, 2004 5:50 am

Also I've made sure firewalls are off on both PCs. Before I couldn't do a thing when they were switched on.
jimmylad007
Green Belt
Green Belt
 
Posts: 171
Joined: Fri Jun 11, 2004 6:16 am

Postby spb251272 » Wed Sep 08, 2004 3:21 am

The access denied error usually means either a firewall is blocking the other pc, or you are not both in the same workgroup. I've had this happen recently when setting up a new wireless network, and it was norton internet security that was blocking the other pc.

MountainMods U2-UFO / Asus A8N SLI Premium
X2 3800+@2.5Ghz / XP90c / 2GB OCZ Gold GE XTC
2 x XFX 7900GT SLI / VF900-CU / 2 x 200GB WD
Tagan EasyCon 530W / Audigy 2 ZS / Logitech G7
spb251272
Black Belt
Black Belt
 
Posts: 813
Joined: Tue Dec 17, 2002 4:30 am
Location: Manchester, UK

Postby Hardware Junkie » Wed Sep 08, 2004 4:47 pm

jimmylad007 wrote:The desktop has the internet connection (yes it's a USB modem). They both have bog standard 10/100 LAN connections on board.

Also I can only access from one way. I can access the laptop's hard drive from the desktop, but when I try to access the desktop's hard drive from the laptop I can't. It does not show up on "my network places" on the laptop, and double clicking the desktop in "view workgroup computers" gives an access denied error.

I don't need it straight away, but it's just when my friend brings his laptop round so we can share files and internet connection then.


Also double check File and Printer Sharing to see if that is enabled on both machines.
"Imagination is the only weapon in the war against reality." -Jules de Gautier

Image
Hardware Junkie
Mobo-fu Master
Mobo-fu Master
 
Posts: 19405
Joined: Thu Jan 25, 2001 1:01 am
Location: 00000h - 0000Fh

Postby Kooshball » Thu Sep 09, 2004 4:21 am

do you really need to create a network setup disk for a 98se and XP combo?
I thought you could just run the standard wizard.
I've had the same problem, but resetting helps.
Kooshball
Green Belt
Green Belt
 
Posts: 116
Joined: Wed Jan 21, 2004 7:15 pm
Location: Spartanburg, South Carolina

Postby dr_st » Thu Sep 09, 2004 5:01 am

Kooshball wrote:do you really need to create a network setup disk for a 98se and XP combo?
I thought you could just run the standard wizard.
I've had the same problem, but resetting helps.


What standard wizard on Win98SE?

jimmylad007 wrote:I can't share internet connection though. Can you talk me through that? Both machines are on XP.


Well, make sure it's shared properly - go to the Network Connections on the computer which is connected to the USB modem, go to the properties of your internet connection. In the "Advanced" tab you should have an option to enable connection sharing.
dr_st
Black Belt 2nd Degree
Black Belt 2nd Degree
 
Posts: 2191
Joined: Tue May 11, 2004 11:18 pm
Location: Outworld

Next

Return to Networking

Who is online

Users browsing this forum: No registered users and 2 guests