no cursor at lock screen...

Discussions, problem solving, and tips and trick for operating systems go here. Windows, Mac, and Linux are ok. If you want to fight or put down an OS go to The Hundred Year War Forum. It will not be tolerated here. Make sure to post what OS is being discussed in the title of your post.

Moderator: The Mod Squad

Post Reply
bdub
Black Belt 3rd Degree
Black Belt 3rd Degree
Posts: 3680
Joined: Wed Feb 19, 2003 2:12 am
Location: Washington D.C.

no cursor at lock screen...

Post by bdub »

a win10 machine here acts differently recently... on boot, the lock screen shows with no login line in the middle, and no cursor showing. if I move the mouse then click or hit a key on the kb, the cursor shows and I can login. if I do nothing for a minute or so, the screen will go black after about 2-3 minutes... but hitting a key or moving the cursor brings everything back.
i'm wondering if anybody else has noticed this change lately, and which windows update caused it, IF it was an update that made this new behavior.
also if there is any way to tweak the timing of the black screen to show a little more delayed than presently, or always show the logon screen and cursor?
I've done a search online, but haven't found any info about this new (to me) behavior.
TIA.

I should mention that my current setting in the OS call for the monitor to go black after 20 minutes without an input device being used, so that's not the answer on the black screen at logon, which shows just 2-3 minutes after lock screen shows.
also, this behavior is the same in regards to the black screen happening after a short while of being on the lock screen when locking the computer from the start menu, as it is on bootup.
my main rig...
asrock 970 extreme3
AMD FX-6300 Vishera CPU
zalman cpns5x performa hs/fan
crucial ballistix 2x4gb sport ddr3-1333
powercolor ax7750 1GBK3-H vga
antec neo he 650r
samsung 840 EVo SSD 120 GB
toshiba 2TB HDD 64M cache sata3
seagate 1TB HDD 64M cache sata3
hitachi 2TB HDD 64M cache sata3
plextor PX-891SAF dvdrw
optiarc ad-7240s sata dvdrw (nec chipset)
User avatar
evasive
Mobo-fu Master
Mobo-fu Master
Posts: 37629
Joined: Sun May 06, 2001 12:01 am
Location: Netherlands
Contact:

Re: no cursor at lock screen...

Post by evasive »

The 20 minute timeout is likely in the user settings, if not logged in yet, there are no user settings active.

What you describe is what I am seeing too, I think it changed 2 releases ago so with one of the versioned upgrades.
We hate rut, but we fear change.
********************************
System error, strike any user to continue...
bdub
Black Belt 3rd Degree
Black Belt 3rd Degree
Posts: 3680
Joined: Wed Feb 19, 2003 2:12 am
Location: Washington D.C.

Re: no cursor at lock screen...

Post by bdub »

thanks for corroborating what i'm seeing here. cheers! if it did a happen a while back (before 1909), I did not notice it... maybe just never got the chance to sit at too many different machines with lock screen on.
my main rig...
asrock 970 extreme3
AMD FX-6300 Vishera CPU
zalman cpns5x performa hs/fan
crucial ballistix 2x4gb sport ddr3-1333
powercolor ax7750 1GBK3-H vga
antec neo he 650r
samsung 840 EVo SSD 120 GB
toshiba 2TB HDD 64M cache sata3
seagate 1TB HDD 64M cache sata3
hitachi 2TB HDD 64M cache sata3
plextor PX-891SAF dvdrw
optiarc ad-7240s sata dvdrw (nec chipset)
bdub
Black Belt 3rd Degree
Black Belt 3rd Degree
Posts: 3680
Joined: Wed Feb 19, 2003 2:12 am
Location: Washington D.C.

Re: no cursor at lock screen...

Post by bdub »

found this registry fix to change the way the lock screen works... "Get Rid of the Useless Lock Screen"

"HKEY_LOCAL_Machine\SOFTWARE\Policies\Microsoft\Windows and create a new key called Personalization if it doesn't already exist. Within the Personalization key, create a DWORD (32-bit) value called NoLockScreen and set it to 1."

that makes the machine show the password input area right away when you boot the os and if you sign out of the user account. the 2-3 minute timing until a black screen on the lock screen at first boot and if the computer is locked did not change... so no fix for that yet.

another fix I found was this one that forces the machine to shut down without asking to force it when it senses programs might be open (even if there is none). "Force Windows to Close Apps at Shutdown"

"navigate to \HKEY_CURRENT_USER\Control Panel\Desktop and create three strings (if they don't already exist). Create AutoEndTasks and set it to 1, create WaitToKillAppTimeOut and set it to 2000. Finally, create HungAppTimeOut and set that to 2000 also. These automatically force-close any open apps after a 2000-millisecond (2 second) delay (shorter delays could be problematic because it wouldn't give apps that are closing time to close themselves)."

these changes come from this article...
https://www.tomshardware.com/how-to/win ... -to-change
my main rig...
asrock 970 extreme3
AMD FX-6300 Vishera CPU
zalman cpns5x performa hs/fan
crucial ballistix 2x4gb sport ddr3-1333
powercolor ax7750 1GBK3-H vga
antec neo he 650r
samsung 840 EVo SSD 120 GB
toshiba 2TB HDD 64M cache sata3
seagate 1TB HDD 64M cache sata3
hitachi 2TB HDD 64M cache sata3
plextor PX-891SAF dvdrw
optiarc ad-7240s sata dvdrw (nec chipset)
trollypoop
Pilgrim
Pilgrim
Posts: 1
Joined: Sat Jun 27, 2020 4:17 am

Re: no cursor at lock screen...

Post by trollypoop »

^^ Thanks a lot for the registry trick!!
Post Reply