Where can i find bios LBA option for my hdd?

Moderator: The Mod Squad

Where can i find bios LBA option for my hdd?

Postby rohitsz » Sat Jan 29, 2005 1:18 am

Greetings there,
my system description goes like this...
Board: INTEL D845WN
Operating System: Windows 98
System Memory: 523,528 K
BIOS Version: P10 (HV84510A.86A.0038.P10.0204151346)
BIOS Release Date: 04/15/2002
BIOS Size: 512 K
HDD: 2x40G(seagate)
i installed lin on my hdd which had win98/winxp. i was running these oses smoothly until i decided to give linux some more space, also i swapped my master-slave hdd's and win installation went smooth. when i installed lin(the same i had previosly installed) it gave me a warning of reading faulty values of my hdd. something related to chs/lba.
when i went to the bios configuration screen, i could not find any such option. while going thru intel's site i found i have a P10 bios patch while the P8 patch for the same board supports LBA..
kindly guide me how enable lba for both of my hdd's..

thanks,
rohit.
Namaste,
I honour the spirit in you which is also in me.
rohitsz
Pilgrim
Pilgrim
 
Posts: 7
Joined: Tue Jan 25, 2005 7:44 am

Postby evasive » Sat Jan 29, 2005 5:55 am

I'm loosing track halfway your story. which has disk installed what? I somehow have a feeling you swapped disks one too many times.
We hate rut, but we fear change.
********************************
System error, strike any user to continue...
evasive
Mobo-fu Master
Mobo-fu Master
 
Posts: 37389
Joined: Sun May 06, 2001 12:01 am
Location: Netherlands

Postby Copper » Sat Jan 29, 2005 12:37 pm

clear cmos and load failsafe defaults in bios , this should auto detect your drives
"Only two thing are infinite, the universe and human stupidity,and Im not sure about the former." Albert Einstein (1879 - 1955)
Copper
Black Belt 5th Degree
Black Belt 5th Degree
 
Posts: 8640
Joined: Mon Jul 14, 2003 12:38 pm
Location: Midlands UK

elaborating my problem

Postby rohitsz » Sat Jan 29, 2005 11:16 pm

Greetings there..
allow me to elaborate more...
my system configuration was like this..

i had two hdd each 40G seagate. one was older than the other.. so i'll address them as old/new drive...
i had my new drive as primary and old drive as secondary.
new drive had win98 and winxp installed on it.
old drive had 4G of linux partition and the rest was fat32. while intalling linux i did not come across any LBA/CHS warnings...

my winXP partition was at a stand still due to virus attack, hence i decided to do away with xp and stick with linux and win98.

i wanted to make my old drive as primary and new as secondary.(here is the swapping part)
so after saving my data in the old drive, i formatted the new drive and copied back my data into the new drive. after that i formatted my old drive and intalled win98 on it and put data back on it. so now i have my win98 and old drive and data inplace on the old drive. the new drive was ready for linux intallation.
it is here i faced problem/warnings listed here

so, i did not 'mess' with these LBA settings except for making my old drive as primary and new drive as secondary. now after searching the web, asking at linux-forums, i have comto know of how to get things right... and now i cannnot find my LBA settings in my bios...!

sorry for a 'mixed' explanation .. hope i made the problem a bit clearer!

thanks,
rohit.
Namaste,
I honour the spirit in you which is also in me.
rohitsz
Pilgrim
Pilgrim
 
Posts: 7
Joined: Tue Jan 25, 2005 7:44 am

Postby evasive » Sun Jan 30, 2005 12:46 am

Is there anything left on your old drive and are you installing with only that drive in your machine? I think it has some leftover partition somewhere that is not according to the rules. Check with only your old (problem) drive in your system and fdisk to see what is on it, kill off any partitions, then try the linux install again.
We hate rut, but we fear change.
********************************
System error, strike any user to continue...
evasive
Mobo-fu Master
Mobo-fu Master
 
Posts: 37389
Joined: Sun May 06, 2001 12:01 am
Location: Netherlands

Postby rohitsz » Sun Jan 30, 2005 11:32 am

Greetings there...
while re-vamping my drives, i totally erased every partition on it and started with making fresh partitions and formatted them.
this i did for both of my drives. so there is no way anything/portion of the drive being left that is causing the trouble.
here you can see the fdisk result for both my drives...(i did this using LINUX LIVE-CD called knoppix)
http://www.geocities.com/rohitsz2/partition.html

also how can i get LBA mode in my BIOS configuration screen?
thanks,
rohit.
Namaste,
I honour the spirit in you which is also in me.
rohitsz
Pilgrim
Pilgrim
 
Posts: 7
Joined: Tue Jan 25, 2005 7:44 am

still can not find LBA on BIOS configuration screen!

Postby rohitsz » Sat Feb 05, 2005 11:51 pm

Greetings there...

i have 2x40G seagate ST340810 A type drives.

The product info link of my segate HDD at seagate
http://www.seagate.com/support/disc/spe ... 0810a.html
says:"Set CMOS hard drive setup to Auto-Detect with LBA mode enabled."

The bios product change notification page
http://developer.intel.com/design/pcn/M ... 023340.pdf
says:"Added support for 48 bit LBA mode"
while i have recently flashed my bios to P15 patch version.

My system Info from Intel Active Monitor

I N T E L (R) A C T I V E M O N I T O R

System Information Report
2/6/05 1:25:48 PM

***************************************************************************
General Information
***************************************************************************
Product name Genuine Intel(R) Pentium(R) 4 processor based system
Board model Genuine Intel(R) D845WN system board
OS version Windows* 98 SE version 4.10 build 2222
OS memory 523,508 KB RAM

***************************************************************************
Processor
***************************************************************************
Processor Genuine Intel(R) Pentium(R) 4 processor
Processor speed 2.00 GHz
Bus speed 400 MHz
L1 cache Data Cache 8KB, Execution Trace Cache 12K Micro-ops
L2 cache Advanced Transfer Cache 256KB
Form factor ZIF Socket
Stepping 4

***************************************************************************
System
***************************************************************************
Physical memory 512 MB RAM
Memory speed 133 MHz
Memory type SDRAM, Synchronous
Form factor DIMM
BIOS date 05/25/2003
BIOS size 512 KB
BIOS version P15 (HV84510A.86A.0050.P15.0305252001)

(removed report on internal like sensors/fans etc)
***************************************************************************
End of Report
***************************************************************************

*Third-party brands and names are the property of their respective owners.



My problem:
i am able to see the Auto-Detect option in my bios, but unable to see the LBA mode enabled.
kindly help me find the option.

regards,
rohit
Namaste,
I honour the spirit in you which is also in me.
rohitsz
Pilgrim
Pilgrim
 
Posts: 7
Joined: Tue Jan 25, 2005 7:44 am

Re: still can not find LBA on BIOS configuration screen!

Postby boheemee » Sun Feb 06, 2005 12:33 am

rohitsz wrote:My problem:i am able to see the Auto-Detect option in my bios, but unable to see the LBA mode enabled. kindly help me find the option.

regards,
rohit


According to the manual, LBA mode is enabled by default in the bios. You can check it in the Primary/Secondary IDE Master/Slave Submenus. These are located under the Advanced Tab on the Bios menu bar. Should be on page 57 of the manual.
ftp://download.intel.com/support/mother ... nglish.pdf
Image
Image
boheemee
Black Belt
Black Belt
 
Posts: 673
Joined: Sat May 11, 2002 7:28 pm
Location: Tacoma,WA

LBA is not there still!

Postby rohitsz » Sun Feb 06, 2005 2:01 am

Greetings there,

According to the manual, LBA mode is enabled by default in the bios. You can check it in the Primary/Secondary IDE Master/Slave Submenus. These are located under the Advanced Tab on the Bios menu bar. Should be on page 57 of the manual.


i had the manual from intel's cd. but i'd like to point my board is 845WN and not 845HV.

i did go thru the manual and was hoping to see the lba mode..
but it is not there!
also the bios layout is a little different, its not a drop down kinda thing as shown in the manual, but i get to choose one of the menus and the submenu appear on the screen centered, close to the top menu bar.

i am writing what i got at
ADVANCED>IDE CONFIGURATION>PRIMARY IDE MASTER
Code: Select all
Drive Installed [ST340810A]
Type [AUTO]
Max Capacity [40023MB]

Configuration Options selected by BIOS
Multi-Sector Transfers [16 sectors]
PIO mode [MODE4]
Ultra DMA [MODE5]

Cable Detected [80Conductor]



i am only able to change the TYPE category from AUTO to USER but there too i can configure only MULTI-SECTOR TRANSFER,PIO MODE, ULTRA DMA .
so i still can not see enable/disable lba!

also one more thing i'd like to point...
BOOT>SCAN USER FLASH AREA is disabled by default.
does this have any role to play here?

thanks,
rohit.
Namaste,
I honour the spirit in you which is also in me.
rohitsz
Pilgrim
Pilgrim
 
Posts: 7
Joined: Tue Jan 25, 2005 7:44 am

Postby evasive » Mon Feb 07, 2005 4:47 pm

Disk /dev/hda: 77545 cylinders, 16 heads, 63 sectors/track
Warning: extended partition does not start at a cylinder boundary.
DOS and Linux will interpret the contents differently.
Warning: The partition table looks like it was made
for C/H/S=*/255/63 (instead of 77545/16/63).


So it is using translation to 255 heads already. This means it IS using LBA.
We hate rut, but we fear change.
********************************
System error, strike any user to continue...
evasive
Mobo-fu Master
Mobo-fu Master
 
Posts: 37389
Joined: Sun May 06, 2001 12:01 am
Location: Netherlands

Next

Return to BIOS

Who is online

Users browsing this forum: No registered users and 1 guest

cron